Installing TreePlan,
SimVoi, and SensIt
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3.1 INSTALLATION OVERVIEW
TreePlan, SimVoi, and SensIt are decision analysis add-ins for Microsoft Excel 2007 & 2010 &
2013 & 2016 (Windows) and Microsoft Excel 2011 & 2016 (Macintosh).
In general, an Excel add-in is software that adds features to Excel. TreePlan helps you build
decision tree diagrams. SimVoi provides random number generator functions for model inputs,
automates Monte Carlo simulation, and creates Excel charts for a histogram and the cumulative
distribution of each output variable. SensIt performs sensitivity analysis on your worksheet what-if
model and automatically creates simple plots, spider charts, and tornado charts. These instructions
are appropriate for installing each of these products.
For each add-in, all of the functionality, including its built-in help, is a part of the single file in
XLAM format. There is no separate help file. On a Windows computer, the installation does not
create Windows Registry entries, although Excel may use such entries to keep track of its add-ins.

3.2 REMOVING PREVIOUS VERSIONS
Before you open or install an add-in, you must remove any previous versions of the add-in. Excel
will not work correctly if you try to use two versions of the same add-in simultaneously. For
example, if you were using a trial version and now you want to use the standard version, Excel
will regard this as two versions of the same add-in. The same applies to moving from an older to a
newer version, such as from SensIt 1.31 to SensIt 1.46.
If you were using the previous version by “opening” the add-in file, then all you need to do is not
open that previous version. Instead, “open” the new version of the add-in.
But, if you had “installed” the previous version, then you must “uninstall” the old version before
using the new version. For instructions, refer to the appropriate Uninstalling subsection at the end
of each of the Installing sections.

3.3 THE ADD-IN XLAM FILE
Excel can recognize the XLAM file format, but not the ZIP file format. The software, however, is
often available as part of a ZIP file. To get the file into a format Excel can recognize, you will
extract the XLAM file from the downloaded ZIP file.
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A typical filename for the downloaded software would be SensIt-146-Pro-Files.zip. If you are
using a Windows operating system, right-click the ZIP file, and choose Extract All. Then specify a
disk or folder. On a Macintosh, double-click the ZIP file, and the files are automatically extracted
into a folder. Be sure to remember the location of the extracted files.
If you have purchased more than one product, all of the purchased files XLAM files will be
bundled into a single ZIP file.
After you have extracted the XLAM file, it’s now stored on your computer’s disk or in a folder.
To use it in Excel, you have a choice of two methods: to “open” or to “install.” Although the
simplest method is to “open” the add-in, you will need to remember the file’s location each time
you want to use it. If instead you “install” the add-in file, Excel will remember the location for
you.
Depending on the version of Excel and the type of operating system you’re using, go to the
appropriate section of this manual for instructions on either method, with accompanying screen
shots.
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3.4 WINDOWS EXCEL 2007 – 2016 OPENING AN ADD-IN
This is the simplest method. This method is also preferred when using an add-in temporarily on
another computer. Start Excel, and choose File > Open.
Be sure to start Excel and use Excel’s command to open the XLAM file. Do not double-click the
XLAM file to open it. If you open the file by double-clicking, Excel may not execute some
important code in the XLAM file that configures the add-in for your system.
Excel 2007 – 2016 have enhanced levels of security for macros. Each of the add-in files is an
unsigned macro file, which may trigger a security warning in Excel. The steps below allow you to
tell Excel that this macro is trustworthy.
Step 1: Start Excel, and choose File > Options > Trust Center > Trust Center Settings > Add-ins.
Uncheck all checkboxes (as shown below in Figure 3.1), and click OK.

3.4 Windows Excel 2007 – 2016 Opening an Add-in

Figure 3.1 Excel 2007 – 2016 Trust Center Add-Ins Settings

Step 2: In the left column of the Trust Center, click “Macro Settings.” The screen below will
appear.
Figure 3.2 Excel 2007 – 2016 Trust Center Macro Settings

In the section “Macro Settings,” click on Disable all macros with notification, and click OK. On
the screen that follows, again click OK.
Step 3: On the main display of Excel, choose File > Open. Navigate to the location of the add-in
XLAM file, select the file, and click Open. The screen below appears.
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Figure 3.3 Excel 2007 – 2016 Security Notice

Click Enable Macros. For your protection, you will see this screen each time you open and run the
add-in. Always click Enable Macros.
Step 4: At the Excel main display, choose the Add-Ins ribbon. In the Menu Commands area of the
Add-Ins ribbon, select the menu item for the appropriate add-in: SensIt One-Input Plot, SensIt
Tornado-Spider, SimVoi Simulation, or TreePlan Decision Tree. For more information, refer to
the add-in user guide.

3.5 WINDOWS EXCEL 2007 – 2016 INSTALLING AN ADD-IN
Windows operating systems allow multiple users of a single computer to partition and thus share
the computer, with an Administrator maintaining overall control. The following instructions are
appropriate for installing an add-in in either an Administrator or standard user account.
In Windows 7, 8, or 10, copy the XLAM file, and paste it into folder
C:\ Users \ UserName \ AppData \ Roaming \ Microsoft \ AddIns

If you do not see the AppData folder in your UserName folder, it may be hidden. To view the
folder in Windows 7, choose Start > UserName > Organize > Folder and search options > View.
In the Advanced settings, click the option button for “Show hidden files, folders, and drives.” In
the Windows 8 or 10 File Explorer, choose View, and check the box for Hidden items. (In general,
I also recommend checking the box for displaying file name extensions.)
In Windows 7, 8, or 10, after you move a copy of the XLAM file into your AppData \ Roaming \
Microsoft \ AddIns folder, start Excel. Choose File > Options > Add-Ins. Your add-in will initially
be listed in the Inactive Application Add-ins section, as shown below.

3.5 Windows Excel 2007 – 2016 Installing an Add-in
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Figure 3.4 Excel 2007 – 2016 Excel Options Add-Ins Dialog Box

To activate the add-in, select Excel Add-ins in the Manage drop-down list shown above in the
lower part of the screen, and then click the Go button.
The Add-In Manager dialog box appears as shown below in Figure 3.5. Check the box for your
add-in. In this example, the name is SensIt 1.43 Sensitivity Analysis. After you check the box,
click OK.
Figure 3.5 Excel 2007 – 2016 Add-In Manager

Windows Excel 2013 Important Extra Step
In Excel 2013 the add-in menu is not shown automatically the first time when the add-in is loaded.
Instead, close all workbooks, quit Excel, and restart Excel to display the menu. After the first time
you load the add-in, its menu will be displayed each time you start Excel 2013.
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In Excel 2010 the add-in menu appears immediately.
At the Excel main display, choose the Add-Ins ribbon. In the Menu Commands area of the
Add-Ins ribbon, select the menu item for the appropriate add-in: SensIt One-Input Plot, SensIt
Tornado-Spider, SimVoi Simulation, or TreePlan Decision Tree. For more information, refer to
the add-in user guide.

Windows Excel 2007 – 2016 Uninstalling an Add-in
First, to uninstall, uncheck the add-in name from the Add-in list. Start Excel, and choose File >
Options > Add-Ins > Manage Excel Add-Ins > Go. Uncheck the add-in name in the "Add-Ins
available" list, click OK, and exit Excel.
Second, after you exit Excel, delete, move, or rename the XLAM file so that Excel can no longer
find it. To delete the file, use Windows Explorer or File Explorer to navigate to the file location,
select it, and press the Delete key. Or, instead of using Explorer, navigate using Start > Search
programs and files.
After the XLAM file no longer exists where Excel expects to find it, when you next start Excel, if
you select the add-in name in the “Add-Ins available” list, respond to the prompt to delete it from
the list.

3.6 MAC EXCEL 2011 OPENING AN ADD-IN
This is the simplest method of using an add-in in Mac Excel 2011. This method is also preferred
when using an add-in temporarily on another computer.
On Macintosh systems it is important to not double-click the XLAM file to open it. If you open
the file by double-clicking, Excel does not execute some important code in the XLAM file that
configures the add-in for Macintosh. For example, dialog boxes will not be displayed properly.
Launch Mac Excel 2011, and choose File > Open to open the XLAM file. A warning "This
workbook contains macros" is displayed. Click the "Enable Macros" button. The add-in's features
will be available during the current Excel session.
To now use the add-in, on the main menu bar of Mac Excel 2011 click the Tools menu, and
choose SensIt One-Input Plot, SensIt Tornado-Spider, SimVoi Simulation, or TreePlan Decision
Tree.
Shortcut keys are described in the user guide for each add-in. For example, the shortcut key for
TreePlan in Mac Excel 2011 is Option+Cmd+T; that is, hold down the Option and Command
keys, and press the T key.
After you quit Excel, if you want to use the add-in the next time you run Excel, you will have to
open the XLAM file and enable macros again.

3.7 MAC EXCEL 2011 INSTALLING AN ADD-IN
To install an add-in so that its features are available whenever you use Mac Excel 2011, quit
Excel, and perform the following steps just one time.

3.8 Mac Excel 2016 Opening an Add-in

35

Paste a copy of the add-in XLAM file into the Applications > Microsoft Office 2011 > Office >
Add-Ins folder.
Step-by-step: Copy the TreePlan XLAM file (right-click or Ctrl-click the file icon, and
choose Copy from the menu). In the Macintosh Finder, choose Go > Applications. Doubleclick the Microsoft Office 2011 folder, double-click the Office folder, and double-click the
Add-Ins folder. Right-click or Ctrl-click, and choose Paste Item from the menu.
Launch Mac Excel 2011, choose Tools > Add-Ins, check the box for the add-in, and click OK.
To now use the add-in, on the main menu bar of Mac Excel 2011 click the Tools menu, and
choose SensIt One-Input Plot, SensIt Tornado-Spider, SimVoi Simulation, or TreePlan Decision
Tree.
Shortcut keys are described in the user guide for each add-in. For example, the shortcut key for
TreePlan in Mac Excel 2011 is Option+Cmd+T; that is, hold down the Option and Command
keys, and press the T key.

Mac Excel 2011 Uninstalling an Add-in
First, to uninstall, start Excel, choose Tools > Add-Ins, uncheck the add-in file name in the "AddIns available" list, and click OK.
Second, quit Excel, and then delete, move, or rename the XLAM file so that Excel can no longer
find it.
The next time you start Excel, Excel may notify you that it cannot find the add-in file.

3.8 MAC EXCEL 2016 OPENING AN ADD-IN
This is the simplest method of using an add-in in Mac Excel 2016. This method is also preferred
when using an add-in temporarily on another computer.
On Macintosh systems it is important to not double-click the XLAM file to open it. If you open
the file by double-clicking, Excel does not execute some important code in the XLAM file that
configures the add-in for Macintosh. For example, dialog boxes will not be displayed properly.
Launch Mac Excel 2016, and choose File > Open to open the XLAM file. A warning "This
workbook contains macros" is displayed. Click the "Enable Macros" button. Also, the add-in may
display a warning about using a shortcut key. The add-in's features will be available during the
current Excel session.
To use the add-in in Mac Excel 2016, you must use the appropriate shortcut key:
SensIt One-Input Plot

Option+Command+P

SensIt Tornado-Spider

Option+Command+S

SimVoi Simulation

Option+Command+V

TreePlan Decision Tree

Option+Command+T

For example, to use TreePlan in Mac Excel 2011, hold down the Option and Command keys, and
press the T key.
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During 2015, Mac Excel 2016 was released initially without any method for adding an item to the
menu or for customizing the ribbon.
After you quit Excel, if you want to use the add-in the next time you run Excel, you will have to
open the XLAM file and enable macros again.

