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3.1 INSTALLATION OVERVIEW 

TreePlan, SimVoi, and SensIt are decision analysis add-ins for Microsoft Excel 2007 & 2010 & 
2013 & 2016 (Windows) and Microsoft Excel 2011 & 2016 (Macintosh).  

In general, an Excel add-in is software that adds features to Excel. TreePlan helps you build 
decision tree diagrams. SimVoi provides random number generator functions for model inputs, 
automates Monte Carlo simulation, and creates Excel charts for a histogram and the cumulative 
distribution of each output variable. SensIt performs sensitivity analysis on your worksheet what-if 
model and automatically creates simple plots, spider charts, and tornado charts. These instructions 
are appropriate for installing each of these products. 

For each add-in, all of the functionality, including its built-in help, is a part of the single file in 
XLAM format. There is no separate help file. On a Windows computer, the installation does not 
create Windows Registry entries, although Excel may use such entries to keep track of its add-ins. 

3.2 REMOVING PREVIOUS VERSIONS 

Before you open or install an add-in, you must remove any previous versions of the add-in. Excel 
will not work correctly if you try to use two versions of the same add-in simultaneously. For 
example, if you were using a trial version and now you want to use the standard version, Excel 
will regard this as two versions of the same add-in. The same applies to moving from an older to a 
newer version, such as from SensIt 1.31 to SensIt 1.46. 

If you were using the previous version by “opening” the add-in file, then all you need to do is not 
open that previous version. Instead, “open” the new version of the add-in.  

But, if you had “installed” the previous version, then you must “uninstall” the old version before 
using the new version. For instructions, refer to the appropriate Uninstalling subsection at the end 
of each of the Installing sections. 

3.3 THE ADD-IN XLAM FILE 

Excel can recognize the XLAM file format, but not the ZIP file format. The software, however, is 
often available as part of a ZIP file. To get the file into a format Excel can recognize, you will 
extract the XLAM file from the downloaded ZIP file. 
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A typical filename for the downloaded software would be SensIt-146-Pro-Files.zip. If you are 
using a Windows operating system, right-click the ZIP file, and choose Extract All. Then specify a 
disk or folder. On a Macintosh, double-click the ZIP file, and the files are automatically extracted 
into a folder. Be sure to remember the location of the extracted files. 

If you have purchased more than one product, all of the purchased files XLAM files will be 
bundled into a single ZIP file. 

After you have extracted the XLAM file, it’s now stored on your computer’s disk or in a folder. 
To use it in Excel, you have a choice of two methods: to “open” or to “install.” Although the 
simplest method is to “open” the add-in, you will need to remember the file’s location each time 
you want to use it. If instead you “install” the add-in file, Excel will remember the location for 
you.  

Depending on the version of Excel and the type of operating system you’re using, go to the 
appropriate section of this manual for instructions on either method, with accompanying screen 
shots. 

 3.4 Unblock the XLAM Add-in File for Windows Excel 

 3.5 Windows Excel 2007 – 2016 Opening an Add-in 

 3.6 Windows Excel 2007 – 2016 Installing an Add-in 

  Windows Excel 2013 & 2016 Important Extra Step 

  Windows Excel 2007 – 2016 Uninstalling an Add-in 

 3.7 Mac Excel 2011 Opening an Add-in 

 3.8 Mac Excel 2011 Installing an Add-in 

  Mac Excel 2011 Uninstalling an Add-in 

 3.9 Mac Excel 2016 Opening an Add-in 

 3.10 Mac Excel 2016 Installing an Add-in 

  Mac Excel 2016 Uninstalling an Add-in 

3.4 UNBLOCK THE XLAM ADD-IN FILE FOR WINDOWS EXCEL 

In 2016 Microsoft released a security update which may affect downloaded XLAM add-in files 
(and XLAM files downloaded in a ZIP file) with Windows Excel. The security update also affects 
XLAM files transferred from another computer.  

After you open or install the add-in XLAM file, the menu item may not appear in the Add-Ins 
ribbon, and the add-in may not respond to the shortcut key. If so, quit Excel, and follow these 
instructions.  

Alternatively, follow these instructions before you open or install the XLAM file. 

1. Use your file manager, e.g., File Explorer, to navigate to the add-in XLAM file on your 
local drive.  

2. Right-click the XLAM file, and choose Properties > General.  

3. If there is an option to Unblock, click the checkbox and click OK.  



Se
th

F

A
> 

Fo

3

Th
an

W

St

ee the example
he dialog box. 

igure 3.1 Exce

After you click t
Open to load t

or more inform

.5 WINDOW

his is the simp
nother compute

We recommend

tart Excel, and

e below, where

el 2007 – 2016

the Unblock ch
the XLAM file

mation, see http

WS EXCEL

lest method. T
er.  

you Unblock t

choose File > 

e the Unblock c

 Unblock XLA

heckbox and cl
e, or follow the

ps://support.mi

L 2007 – 20

his method is a

the XLAM file

Open.  

3.5 Windows

checkbox appe

AM File 

lick the OK bu
e instructions fo

crosoft.com/en

016 OPENI

also preferred w

e first. 

s Excel 2007 – 2

ears in the botto

 

utton, launch Ex
for installation. 

n-us/kb/318150

NG AN AD

when using an

2016 Opening an

om right Secur

xcel, and use E
 

07. 

DD-IN 

n add-in tempor

 Add-in     31 

rity area of 

Excel’s File 

rarily on 



32

B
cl
so

E
un
te

St
U

F

St
ap

F

In
th

2     Chapter 3 In

e sure to start E
lick the XLAM
ome important 

xcel 2007 – 20
nsigned macro
ell Excel that th

tep 1: Start Ex
Uncheck all che

igure 3.2 Exce

tep 2: In the le
ppear. 

igure 3.3 Exce

n the section “M
he screen that f

nstalling TreePlan

Excel first, and
M file to open it

code in the XL

016 have enhan
 file, which ma

his macro is tru

xcel, and choos
eckboxes (as sh

el 2007 – 2016

eft column of th

el 2007 – 2016

Macro Settings
follows, again c

n, SimVoi, and S

d then use Exce
t. If you open t
LAM file that c

nced levels of s
ay trigger a sec
ustworthy.  

se File > Option
hown below in 

 Trust Center A

he Trust Cente

 Trust Center M

s,” click on Dis
click OK.  

SensIt 

el’s command 
the file by doub
configures the 

security for ma
curity warning 

ns > Trust Cen
Figure 3.2), an

Add-Ins Setting

er, click “Macro

Macro Settings

sable all macro

to open the XL
ble-clicking, E
add-in for you

acros. Each of t
in Excel. The 

nter > Trust Ce
nd click OK. 

gs 

o Settings.” Th

s 

os with notifica

LAM file. Do n
Excel may not e
ur system. 

the add-in files
steps below al

enter Settings >

 

he screen below

 

ation, and click

not double-
execute 

s is an 
llow you to 

> Add-ins. 

w will 

k OK. On 



St
X

F

C
ad

St
A
T
th

3

W
th
ap

W

In

C:

If
fo
In
th
w

In
M
be

tep 3: On the m
XLAM file, sele

igure 3.4 Exce

lick Enable M
dd-in. Always 

tep 4: At the E
Add-Ins ribbon,

ornado-Spider
he add-in user g

.6 WINDOW

Windows operat
he computer, w
ppropriate for i

We recommend

n Windows 7, 8

:\ Users \ Us

f you do not see
older in Windo
n the Advanced
he Windows 8 o

we also recomm

n Windows 7, 8
Microsoft \ Add

e listed in the I

main display o
ect the file, and

el 2007 – 2016

acros. For you
click Enable M

Excel main disp
 select the men
, SimVoi Simu
guide. 

WS EXCEL

ting systems al
with an Adminis
installing an ad

you Unblock t

8, or 10, copy t

serName \ App

e the AppData 
ws 7, choose S

d settings, click
or 10 File Expl

mend checking 

8, or 10, after y
dIns folder, star
Inactive Applic

f Excel, choose
d click Open. T

 Security Notic

r protection, yo
Macros. 

play, choose th
nu item for the 
ulation, or Tree

L 2007 – 20

llow multiple u
strator maintai
dd-in in either a

the XLAM file

the XLAM file

pData \ Roami

folder in your
Start > UserNa
k the option bu
lorer, choose V
the box for dis

you move a cop
rt Excel. Choos
cation Add-ins 

3.6 Windows

e File > Open. 
The screen belo

ce 

ou will see this

he Add-Ins ribb
appropriate ad

ePlan Decision

016 INSTAL

users of a singl
ning overall co
an Administrat

e first. 

e, and paste it in

ing \ Microso

UserName fol
me > Organize

utton for “Show
View, and chec
splaying file na

py of the XLA
se File > Optio
section, as sho

s Excel 2007 – 20

Navigate to th
ow appears. 

 

s screen each ti

bon. In the Men
dd-in: SensIt O
n Tree. For mor

LLING AN 

le computer to 
ontrol. The foll
tor or standard

into folder  

oft \ AddIns

lder, it may be 
e > Folder and 
w hidden files, 
ck the box for H
ame extensions

AM file into you
ons > Add-Ins. 
own below. 

016 Installing an

he location of t

ime you open a

nu Commands
One-Input Plot, 
re information,

ADD-IN 

partition and t
lowing instruct

d user account. 

s 

 hidden. To vie
search options
folders, and dr
Hidden items. 
s.) 

ur AppData \ R
Your add-in w

n Add-in     33 

the add-in 

and run the 

s area of the 
SensIt 

, refer to 

thus share 
tions are 

ew the 
s > View. 
rives.” In 
(In general, 

Roaming \ 
will initially 



34

F

T
lo

Th
ad
cl

F

W

In
is
fir

4     Chapter 3 In

igure 3.5 Exce

o activate the a
ower part of the

he Add-In Man
dd-in. In this ex
lick OK. 

igure 3.6 Exce

Windows E

n Excel 2013 &
 loaded. Instea
rst time you lo

nstalling TreePlan

el 2007 – 2016

add-in, select E
e screen, and th

nager dialog bo
xample, the na

el 2007 – 2016

xcel 2013 

& 2016 the add
ad, close all wo
oad the add-in, 

n, SimVoi, and S

 Excel Options

Excel Add-ins i
hen click the G

ox appears as s
ame is SensIt 1

 Add-In Manag

 

& 2016 Imp

-in menu is no
orkbooks, quit E
its menu will b

SensIt 

s Add-Ins Dial

in the Manage 
Go button.  

shown below in
.43 Sensitivity

ger 

portant Ex

t shown autom
Excel, and rest
be displayed ea

log Box 

drop-down lis

n Figure 3.5. C
y Analysis. Afte

xtra Step 

matically the fir
tart Excel to di
ach time you st

st shown above

Check the box f
er you check th

rst time when t
isplay the menu
tart Excel 2013

 

e in the 

for your 
he box, 

the add-in 
u. After the 
3. 



3.7 Mac Excel 2011 Opening an Add-in     35 

In Excel 2010 the add-in menu appears immediately. 

At the Excel main display, choose the Add-Ins ribbon. In the Menu Commands area of the 
Add-Ins ribbon, select the menu item for the appropriate add-in: SensIt One-Input Plot, SensIt 
Tornado-Spider, SimVoi Simulation, or TreePlan Decision Tree. For more information, refer to 
the add-in user guide.  

Windows Excel 2007 – 2016 Uninstalling an Add-in 

First, to uninstall, uncheck the add-in name from the Add-in list. To do so, start Excel, and choose 
File > Options > Add-Ins > Manage Excel Add-Ins > Go. Uncheck the add-in name in the "Add-
Ins available" list, click OK, and exit Excel. 

Second, after you exit Excel, delete, move, or rename the XLAM file so that Excel can no longer 
find it. To delete the file, use Windows Explorer or File Explorer to navigate to the file location, 
select it, and press the Delete key. Or, instead of using Explorer, navigate using Start > Search 
programs and files.  

After the XLAM file no longer exists where Excel expects to find it, when you next start Excel, if 
you select the add-in name in the “Add-Ins available” list, respond to the prompt to delete it from 
the list. 

3.7 MAC EXCEL 2011 OPENING AN ADD-IN 

This is the simplest method of using an add-in in Mac Excel 2011. This method is also preferred 
when using an add-in temporarily on another computer.  

On Macintosh systems it is important to not double-click the XLAM file to open it. If you open 
the file by double-clicking, Excel does not execute some important code in the XLAM file that 
configures the add-in for Macintosh. For example, dialog boxes will not be displayed properly. 

Launch Mac Excel 2011, and choose File > Open to open the XLAM file. A warning "This 
workbook contains macros" is displayed. Click the "Enable Macros" button. The add-in's features 
will be available during the current Excel session.  

To now use the add-in, on the main menu bar of Mac Excel 2011 click the Tools menu, and 
choose SensIt One-Input Plot, SensIt Tornado-Spider, SimVoi Simulation, or TreePlan Decision 
Tree.  

Shortcut keys are described in the user guide for each add-in. For example, the shortcut key for 
TreePlan in Mac Excel 2011 is Option+Cmd+t; that is, hold down the Option and Command keys, 
and press the t key. 

After you quit Excel, if you want to use the add-in the next time you run Excel, you will have to 
open the XLAM file and enable macros again. 

3.8 MAC EXCEL 2011 INSTALLING AN ADD-IN 

To install an add-in so that its features are available whenever you use Mac Excel 2011, quit 
Excel, and perform the following steps just one time.  
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Paste a copy of the add-in XLAM file into the Applications > Microsoft Office 2011 > Office > 
Add-Ins folder. 

Step-by-step: Copy the TreePlan XLAM file (right-click or Ctrl-click the file icon, and 
choose Copy from the menu). In the Macintosh Finder, choose Go > Applications. Double-
click the Microsoft Office 2011 folder, double-click the Office folder, and double-click the 
Add-Ins folder. Right-click or Ctrl-click, and choose Paste Item from the menu.  

Launch Mac Excel 2011, choose Tools > Add-Ins, check the box for the add-in, and click OK. 

To now use the add-in, on the main menu bar of Mac Excel 2011 click the Tools menu, and 
choose SensIt One-Input Plot, SensIt Tornado-Spider, SimVoi Simulation, or TreePlan Decision 
Tree.  

Shortcut keys are described in the user guide for each add-in. For example, the shortcut key for 
TreePlan in Mac Excel 2011 is Option+Cmd+t; that is, hold down the Option and Command keys, 
and press the t key. 

Mac Excel 2011 Uninstalling an Add-in 

First, to uninstall, start Excel, choose Tools > Add-Ins, uncheck the add-in file name in the "Add-
Ins available" list, and click OK. 

Second, quit Excel, and then delete, move, or rename the XLAM file so that Excel can no longer 
find it. 

The next time you start Excel, Excel may notify you that it cannot find the add-in file. 

3.9 MAC EXCEL 2016 OPENING AN ADD-IN 

This is the simplest method of using an add-in in Mac Excel 2016. This method is also preferred 
when using an add-in temporarily on another computer.  

On Macintosh systems it is important to not double-click the XLAM file to open it. If you open 
the file by double-clicking, Excel does not execute some important code in the XLAM file that 
configures the add-in for Macintosh. For example, dialog boxes will not be displayed properly. 

Launch Mac Excel 2016, and choose File > Open to open the XLAM file. A warning "This 
workbook contains macros" is displayed. Click the "Enable Macros" button. Also, the add-in may 
display a dialog box about using a shortcut key. The add-in's features will be available during the 
current Excel session.  

To use the add-in in Mac Excel 2016, you must use the appropriate shortcut key: 

SensIt One-Input Plot Option+Command+p  

SensIt Tornado-Spider Option+Command+s 

SimVoi Simulation Option+Command+v 

TreePlan Decision Tree Option+Command+t 

For example, to use TreePlan in Mac Excel 2016, hold down the Option and Command keys, and 
press the t key. 



3.10 Mac Excel 2016 Installing an Add-in     37 

After you quit Excel, if you want to use the add-in the next time you run Excel, you will have to 
open the XLAM file and enable macros again. 

3.10 MAC EXCEL 2016 INSTALLING AN ADD-IN 
To install an add-in so that its features are available whenever you use Mac Excel 2016, quit 
Excel, and perform the following steps just one time.  

On the topmost menu of Mac Excel 2016, choose Tools > Excel Add-ins. In the Add-ins dialog 
box in the lower left corner, click the Browse button. Navigate to the folder containing your add-in 
XLAM file, select the file, and click Open. The add-in name appears in the “Add-ins available” 
list, and a checkmark indicates it is active. Click OK. A warning "This workbook contains 
macros" is displayed. Click the "Enable Macros" button. Also, the add-in may display a dialog box 
about using a shortcut key. 

Mac Excel 2016 Uninstalling an Add-in 

First, on the topmost menu of Mac Excel 2016, choose Tools > Excel Add-ins. In the "Add-Ins 
available" list, uncheck the add-in name, click OK, and quit Excel. 

Second, after you quit Excel, delete, move, or rename the XLAM file so that Excel can no longer 
find it. Or, rename the folder containing the XLAM file. 

Third, the next time you launch Excel, on the topmost menu choose Tools > Excel Add-ins. In the 
"Add-Ins available" list, check the add-in name. An alert appears with the question “Delete from 
list?”. Click the Yes button. 

Support for Add-ins in Mac Excel 2016 

Compared to other versions of Excel, at the time of this writing in 2018, Excel for Mac 2016 
continues to be an incomplete, evolving software product. It is important that you keep it up-to-
date. On the topmost menu choose Excel > About Microsoft Excel to see the version, and choose 
Help > Check for Updates to get a newer version. 

If you have a problem using one of our analytic add-ins, browse to the product Support page, and 
look at the Q&A items and version history to get the latest information: 

 http://treeplan.com/support/ 

 http://sensitpro.com/support/ 

 http://simvoi.com/support/ 

 

 


