
 

Decision Trees 
Using TreePlan  16 
 

16.1 TREEPLAN OVERVIEW 
TreePlan is a decision tree add-in for Windows Excel 2010 & 2013 & 2016 & 2019 & 365 and 
Mac Excel 2016 & 2019 & 365. 

TreePlan helps you build a decision tree diagram in an Excel worksheet using dialog boxes. 
Decision trees are useful for analyzing sequential decision problems under uncertainty. Your 
decision tree model may include various controllable alternatives (e.g., whether to introduce a new 
product, whether to bid on a new project) and uncontrollable uncertainties (e.g., possible demand 
for a product, whether you're awarded a contract), arranged in chronological order. TreePlan 
automatically includes formulas for summing cash flows to obtain outcome values and for 
calculating rollback values for determining the optimal strategy.  

To use TreePlan, you 
 (1) open a new worksheet, 
 (2) choose TreePlan > TreePlan to build a new decision tree diagram, 
 (3) select a node to change the structure of your decision tree, 
 (4) enter branch names, cash flows, and probabilities, and 
 (5) determine the optimal strategy from TreePlan's results. 

All of TreePlan’s functionality, including its built-in help, is a part of the TreePlan XLAM file. 
There is no separate setup file or help file. When you use TreePlan on a Windows computer, 
TreePlan does not create any Windows Registry entries (although Excel may use such entries to 
keep track of its add-ins). 

16.2 BUILDING A DECISION TREE IN TREEPLAN 
With Windows Excel or Mac Excel, you can start TreePlan by choosing the TreePlan ribbon and 
clicking the TreePlan button. In these instructions we write “TreePlan > TreePlan.” 

An alternative is to use the shortcut key: Control+Shift+T on Windows Excel, or 
Option+Command+t on Mac Excel. 

If the worksheet doesn't have a decision tree, TreePlan prompts you with a dialog box with three 
options; choose New Tree to begin a new tree. TreePlan draws a default initial decision tree with 
its upper left corner at the selected cell. For example, the figure below shows the initial tree when 
cell C3 is selected before creating the new tree. 
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16.4 TREEPLAN INPUTS AND FORMULAS 

Figure 16.7 Influence Chart of TreePlan Inputs and Formulas 

 

Figure 16.8 Explanation of Formulas 

 

16.5 STEP-BY-STEP TREEPLAN TUTORIAL 
A decision tree can be used as a model for a sequential decision problem under uncertainty. A 
decision tree describes graphically the decisions to be made, the events that may occur, and the 
outcomes associated with combinations of decisions and events. Probabilities are assigned to the 
events, and values are determined for each outcome. A major goal of the analysis is to determine 
the best decisions. 

Decision tree models include such concepts as nodes, branches, terminal values, strategy, payoff 
distribution, certain equivalent, and the rollback method. The following problem illustrates the 
basic concepts. 

Branch Inputs Cell Formulas Defined Name

Optional

Optional

Cash Flow

Probability

Terminal Node
Endpoint Value

Event Node
Rollback Value

Decision Node
Choice Indicator

Decision Node
Rollback Value

RT (Risk Tolerance)

Location Formula

Endpoint Value
at Terminal Node

SUM of branch cash flows

Rollback Value
at Event Node

IF probabilities SUM to 
approximately one, then SUM the 
products of probabilities times 
subsequent rollback values

Rollback Value
at Decision Node

MAX or MIN of subsequent rollback 
values

Choice Indicator
at Decision Node

Nested IF functions
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DriveTek Problem 

DriveTek Research Institute discovers that a computer company wants a new storage device for a 
proposed new computer system. Since the computer company does not have research people 
available to develop the new storage device, it will subcontract the development to an independent 
research firm. The computer company has offered a fee of $250,000 for the best proposal for 
developing the new storage device. The contract will go to the firm with the best technical plan 
and the highest reputation for technical competence. 

DriveTek Research Institute wants to enter the competition. Management estimates a cost of 
$50,000 to prepare a proposal with a fifty-fifty chance of winning the contract. 

However, DriveTek's engineers are not sure about how they will develop the storage device if they 
are awarded the contract. Three alternative approaches can be tried. The first approach is a 
mechanical method with a cost of $120,000, and the engineers are certain they can develop a 
successful model with this approach. A second approach involves electronic components. The 
engineers estimate that the electronic approach will cost only $50,000 to develop a model of the 
storage device, but with only a 50 percent chance of satisfactory results. A third approach uses 
magnetic components; this costs $80,000, with a 70 percent chance of success. 

DriveTek Research can work on only one approach at a time and has time to try only two 
approaches. If it tries either the magnetic or electronic method and the attempt fails, the second 
choice must be the mechanical method to guarantee a successful model. 

The management of DriveTek Research needs help in incorporating this information into a 
decision to proceed or not. 

[Source: The storage device example is adapted from Spurr and Bonini, Statistical Analysis for 
Business Decisions, Irwin.] 

Nodes and Branches 

Decision trees have three kinds of nodes and two kinds of branches. A decision node is a point 
where a choice must be made; it is shown as a square. The branches extending from a decision 
node are decision branches, each branch representing one of the possible alternatives or courses of 
action available at that point. The set of alternatives must be mutually exclusive (if one is chosen, 
the others cannot be chosen) and collectively exhaustive (all possible alternatives must be included 
in the set). 

There are two major decisions in the DriveTek problem. First, the company must decide whether 
or not to prepare a proposal. Second, if it prepares a proposal and is awarded the contract, it must 
decide which of the three approaches to try to satisfy the contract. 

An event node is a point where uncertainty is resolved (a point where the decision maker learns 
about the occurrence of an event). An event node, sometimes called a "chance node," is shown as 
a circle. The event set consists of the event branches extending from an event node, each branch 
representing one of the possible events that may occur at that point. The set of events must be 
mutually exclusive (if one occurs, the others cannot occur) and collectively exhaustive (all 
possible events must be included in the set). Each event is assigned a subjective probability; the 
sum of probabilities for the events in a set must equal one. 

The three sources of uncertainty in the DriveTek problem are: whether it is awarded the contract 
or not, whether the electronic approach succeeds or fails, and whether the magnetic approach 
succeeds or fails. 
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In general, decision nodes and branches represent the controllable factors in a decision problem; 
event nodes and branches represent uncontrollable factors. 

Decision nodes and event nodes are arranged in order of subjective chronology. For example, the 
position of an event node corresponds to the time when the decision maker learns the outcome of 
the event (not necessarily when the event occurs). 

The third kind of node is a terminal node, representing the final result of a combination of 
decisions and events. Terminal nodes are the endpoints of a decision tree, shown as the end of a 
branch on hand-drawn diagrams and as a triangle on computer-generated diagrams. 

The following table shows the three kinds of nodes and two kinds of branches used to represent a 
decision tree. 

Figure 16.9 Nodes and Symbols 
Type of Node  Written Symbol  Computer Symbol  Node Successor 
Decision  square  square  decision branches 
Event  circle  circle  event branches 
Terminal  endpoint  triangle or bar  terminal value 

Terminal Values 

Each terminal node has an associated terminal value, sometimes called a payoff value, outcome 
value, or endpoint value. Each terminal value measures the result of a scenario: the sequence of 
decisions and events on a unique path leading from the initial decision node to a specific terminal 
node. 

To determine the terminal value, one approach assigns a cash flow value to each decision branch 
and event branch and then sum the cash flow values on the branches leading to a terminal node to 
determine the terminal value. In the DriveTek problem, there are distinct cash flows associated 
with many of the decision and event branches. Some problems require a more elaborate value 
model to determine the terminal values. 

The following diagram shows the arrangement of branch names, probabilities, and cash flow 
values on an unsolved tree. 
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Figure 16.15 Initial Event Branches 

 

 5. Select cell H2, and enter Awarded contract. Select cell H4, and enter 250000. Select cell 
H7, and enter Not awarded contract. 

Figure 16.16 Event Branches With Names and Cash Flow 

 

 6. Select cell J3. Choose TreePlan > TreePlan. In the TreePlan Terminal Node dialog box, 
select Change To Decision Node, select Three Branches, and click OK. The tree is 
redrawn. 
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Figure 16.17 Subsequent Decision Branches 

 

 7. Select cell L2, and enter Use mechanical method. Select cell L4, and enter –120000. 
Select cell L7, and enter Try electronic method. Select cell L9, and enter –50000. Select 
cell L12, and enter Try magnetic method. Select cell L14, and enter –80000.  

Figure 16.18 Subsequent Decision Branches With Names and Cash Flows 

 

 8. Select cell N8. Choose TreePlan > TreePlan. In the TreePlan Terminal Node dialog box, 
select Change To Event Node, select Two Branches, and click OK. The tree is redrawn. 
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Figure 16.19 Branches for Electronic Method Uncertainty 

 

 9. Select cell P7, and enter Electronic success. Select cell P12, and enter Electronic 
failure. Select cell P14, and enter –120000. 

Figure 16.20 Branch Names and Cash Flows for Electronic Method Uncertainty 

 

 10. Select cell N18. Choose TreePlan > TreePlan. In the TreePlan Terminal Node dialog box, 
select Change To Event Node, select Two Branches, and click OK. The tree is redrawn. 
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Figure 16.21 Branches for Magnetic Method Uncertainty 

 

 11. Select cell P16, and enter .7. Select cell P17, and enter Magnetic success. Select cell 
P21, and enter .3. Select cell P22, and enter Magnetic failure. Select cell P24, and enter 
–120000. 
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Figure 16.22 Complete Diagram Before Formatting 

 

 12. Rename the sheet tab Original. Save the workbook. 

Interpreting the Results 

The $30,000 terminal value on the far right of the diagram in cell S13 is associated with the 
following scenario: 

Figure 16.23 Evaluation of a Scenario 
 
 Branch Type  Branch Name  Cash Flow 
 Decision  Prepare proposal  –$50,000 
 Event  Awarded contract  $250,000 
 Decision  Try electronic method  –$50,000 
 Event  Electronic failure (Use mechanical method)  –$120,000 

   Terminal value  $30,000 
 

TreePlan put the formula =SUM(P14,L11,H12,D20) into cell S13 for determining the terminal 
value.  

Other formulas, called rollback formulas, are in cells below and to the left of each node. These 
formulas are used to determine the optimal choice at each decision node. 

In cell B26, a formula displays 1, indicating that the first branch is the optimal choice. Thus, the 
initial choice is to prepare the proposal. In cell J11, a formula displays 2, indicating that the 
second branch (numbered 1, 2, and 3, from top to bottom) is the optimal choice. If awarded the 
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14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34

A B C D E F G H I J K L M N O P Q R S

Use mechanical method
80000

-120000 80000

0.5
Electronic success

150000
0.5 Try electronic method 0 150000
Awarded contract

2 -50000 90000 0.5
250000 90000 Electronic failure

30000
-120000 30000

0.7
Magnetic success

Prepare proposal 120000
Try magnetic method 0 120000

-50000 20000
-80000 84000 0.3

Magnetic failure
0

-120000 0

1 0.5
20000 Not awarded contract

-50000
0 -50000

Don't prepare proposal
0

0 0



21

co
ab

F

Th
m

 

 

F

 

12     Chapter 16

ontract, DriveT
bout interpretat

Formatting 

he following st
may choose to u

13. Right-c
left cor

14. On she
TreePla
Cells an
probab

igure 16.24 Tr

15. Select c
that the
OK. W
the Ali
Cells. I
choose
-$1,234

6 Decision Trees 

Tek should try 
tion. 

the Tree D

teps show how
use other forma

click the sheet 
rner of the Mov

eet Original (2)
an > TreePlan.
nd the Branch 
ility cells selec

reePlan Select 

cell H12. Choo
e option button

With all branch c
gn Left button
In the Format C
 Currency; typ
4 for Negative 

Using TreePlan

the electronic m

Diagram 

w to use TreePl
ats for your ow

tab, and choos
ve Or Copy dia

, if the probabi
 In the TreePla
Probability ch

cted, click the A

Dialog Box 

ose TreePlan >
n for Cells and
cash flow cells
. With those ce
Cells dialog bo
pe 0 (zero) for D

Numbers. Clic

method. A sub

an and Excel f
wn tree diagram

se Move Or Co
alog box, check

ilities are not le
an Select dialog

heckbox are sel
Align Left butt

> TreePlan. In t
Branch Cash F

s selected, if th
ells still selecte
ox, click the Nu
Decimal Places
ck OK. 

bsequent chapte

features to form
ms. 

opy from the sh
k the Create A

eft-aligned, sel
g box, verify th
lected, and clic
ton. 

the TreePlan S
Flow checkbox
he cash flows a
ed, choose Hom
umber tab. In th
s; select $ in th

er provides mo

mat the tree dia

hortcut menu. I
A Copy box, and

lect cell H9. C
hat the option b

ck OK. With al

 

elect dialog bo
x are selected, a
are not left-alig
me > Format >
he Category lis
he Symbol list 

ore details 

agram. You 

In the lower 
d click OK. 

hoose 
button for 
ll 

ox, verify 
and click 

gned, click 
> Format 
st box, 
box; select 



F

 

 

igure 16.25 Ex

16. Select c
that the
With al
of step 

17. Select c
the opt
With al
formatt

xcel Format Ce

cell I12. Choos
e option button
ll rollback cell
16 above. 

cell S3. Choos
ion button for 
ll terminal valu
ting of step 16 

ells Dialog Box

se TreePlan > T
n for Cells and 
s selected, cho

e TreePlan > T
Cells and the T
ue cells selecte
above. 

x 

TreePlan. In th
the Rollback C

oose Format > C

TreePlan. In the
Terminal Value
ed, choose Form

16.5 Step-by-S

 

he TreePlan Se
CE checkbox a
Cells. Repeat t

e TreePlan Sel
e checkbox are
mat > Cells. Re

Step TreePlan Tu

elect dialog box
are selected, an
the Currency fo

lect dialog box
e selected, and 
epeat the Curre

Tutorial     213 

x, verify 
nd click OK. 
ormatting 

x, verify that 
click OK. 

ency 



214     Chapter 16 Decision Trees Using TreePlan 

Figure 16.26 Complete DriveTek Decision Tree 

 

 18. Right-click the sheet tab, choose Rename from the shortcut menu, and enter Formatted. 
Save the workbook. 

Displaying Model Inputs 

When you build a decision tree model, you may want to discuss the model and its assumptions 
with co-workers or a client. For such communication it may be preferable to hide the results of 
formulas that show rollback values and decision node choices. The following steps show how to 
display only the model inputs. 

 19. Right-click the sheet tab, and choose Move Or Copy from the shortcut menu. In the lower 
left corner of the Move Or Copy dialog box, check the Create A Copy box, and click OK. 

 20. On sheet Formatted (2), select cell B1. Choose TreePlan > TreePlan. In the TreePlan 
Select dialog box, verify that the option button for Columns and the Node checkbox are 
selected, and click OK. With all node columns selected, choose Home > Format > Format 
Cells > Number. In the Category list box, select Custom. Select the entry in the Type edit 
box, and type ;;; (three semicolons). Click OK. 
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A B C D E F G H I J K L M N O P Q R S

Use mechanical method
$80,000

-$120,000 $80,000

0.5
Electronic success

$150,000
0.5 Try electronic method $0 $150,000
Awarded contract
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$250,000 $90,000 Electronic failure

$30,000
-$120,000 $30,000

0.7
Magnetic success

Prepare proposal $120,000
Try magnetic method $0 $120,000

-$50,000 $20,000
-$80,000 $84,000 0.3

Magnetic failure
$0

-$120,000 $0

1 0.5
$20,000 Not awarded contract

-$50,000
$0 -$50,000

Don't prepare proposal
$0

$0 $0
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 25. To print the tree diagram from Word, in Excel select the tree diagram range. On Excel’s 
Page Layout ribbon, uncheck Gridlines View. On Excel’s Home ribbon, click (Clipboard) 
Copy. In Word, select the insertion point, and on Word’s Home ribbon, click the 
(Clipboard) Paste dropdown arrow, and click Paste as Picture. 

Figure 16.28 DriveTek Without Rollback Values 

 

Alternative Model 

If you want to emphasize that the time constraint forces DriveTek to use the mechanical approach 
if they try either of the uncertain approaches and experience a failure, you can change the terminal 
nodes in cells R13 and R23 to decision nodes, each with a single branch.  
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TreePlan uses the name RT to represent the risk tolerance parameter of the exponential utility 
function. The names A and B determine scaling. When you choose to use exponential utility, if the 
names A, B, and RT do not already exist in the worksheet or workbook, they are initially defined 
as A=1, B=1, and RT=999999999999.  

In Windows Excel you can change the values of defined names using Formulas > Name Manager 
> Edit.  

In Mac Excel you can change the values of defined names by choosing (from the topmost menu) 
Insert > Name > Define Name or by choosing Formulas > Define Name. In the Define Name 
dialog box, after you select a name in the “Names in workbook” list box, enter a new value in the 
“Select the range of cells” edit box, and click the OK button. 
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