Support for TreePlan Decision Tree, SensIt Tornado Chart, and SimVoi Monte Carlo Simulation Add-ins

For Mac Excel 2011-2016 and
Windows Excel 2010-2013-2016

If you have a question and you cannot find an answer here, send e-mail to Mike Middleton <Mike@TreePlan.com>. Include your version of Excel and details about what you have done (keystrokes and mouse-clicks) and what happens or doesn’t happen.


Purchase Questions and Answers

How can I purchase add-ins?

  • On the product page of this website, click the Buy … button to go to the website of MyCommerce Digital River, our secure order-processing service partner.
  • At the top of the secure MyCommerce Your Cart Contents webpage, specify currency, language, and quantity.
  • Pricing for a quantity discount is shown in a table on each product page of this website. After you enter a quantity, the same prices appear on the secure MyCommerce webpage.
  • In the Billing Information section of the secure MyCommerce webpage, enter an email address that can receive the confirmation email message from MyCommerce. That email message will contain the software download link.
    • Optionally, if you want the purchase to refer to a business entity, select the company name option (instead of first name, last name).
    • Optionally, if you want the purchase to explicity include address information, check the Show more input fields box.
    • Optionally, if you are purchasing for another person or company, first check the Show more input fields box and then clear The Recipient or Licensee is the same as the Purchaser checkbox.
  • In the Payment Information section, enter your credit card information or select one of the other methods of payment.

 

Download Questions and Answers

How can I download the software?

  • After you purchase, MyCommerce Digital River will send a confirmation email message to the email address you specified.
  • If you do not see the email message within several minutes, check your spam and junk folders.
  • The email message contains the URL link where you can immediately download the software as a compressed ZIP file.
  • The download link will expire one month after the time of purchase, so be sure to download the software immediately.
  • When you download the ZIP file, be sure to remember the location of the ZIP file on your computer.

 

Install Questions and Answers

What are important first steps for using the software?

  • After you download the compressed ZIP file from the MyCommerce Share-it Digital River web site, right-click (Windows) or double-click (Macintosh) the ZIP file to extract the XLAM add-in(s) and other files.
  • If you are using a Windows computer, right-click the extracted add-in XLAM file, choose Properties > General, check the box to Unblock the file, and click OK.
  • If you were using a previous version of the add-in, delete the old version of the XLA or XLAM file from your computer.

What is a fast way to start using the software?
Run Excel. Use Excel’s File > Open command to load the XLAM add-in file.

How do I install the add-in so it is always available?
Installation is simple but is not automated. Refer to the extracted How-To-Install-Add-In PDF file for detailed installation instructions.

How can I learn about the features of the software?
For software details and tutorial, refer to the Guide PDF file(s) extracted from the ZIP file.

Are the add-ins compatible with my computer?
The TreePlan, SensIt, and SimVoi add-ins are appropriate for all up-to-date language versions of Mac Excel and Windows Excel that we and our customers have tested.

What if I purchased multiple licenses?
If you have made a volume purchase, you may duplicate and distribute the downloaded file to the users covered by your licenses. To avoid confusion, the purchaser is the point of contact with TreePlan Software for volume purchases.

 

Refund Questions and Answers

How can I get a refund?

Uninstall the add-in, delete the XLAM add-in file and ZIP file from your storage devices and computer, empty the Trash or Recycle Bin, and send an email to Mike Middleton <Mike@TreePlan.com> stating that you have done so and that you request a refund. For faster processing, include the nine-digit ShareIt Ref #.

Back to top

 

All Add-ins Questions and Answers

This section has information related to all of our add-ins.

For information specific to a single add-in, see the TreePlan Q & A, SensIt Q & A, or SimVoi Q & A section.

In Windows Excel, why doesn’t the menu item appear in the Add-Ins ribbon, and why doesn’t the add-in respond to the shortcut key?

  • In July 2016 Microsoft released a security update which may affect downloaded XLA and XLAM add-in files with Windows Excel 2013 and 2016. After you load the add-in XLAM file, if the menu item does not appear in the Add-Ins ribbon and the add-in does not respond to the shortcut key, quit Excel. Use your file manager to navigate to the add-in XLAM file on your local drive. Right-click the XLAM file, and choose Properties > General. If there is an option to Unblock, click the checkbox and click OK. Then launch Excel, and use Excel’s File > Open to load the XLAM file, or follow the instructions for installation. For more information, see https://support.microsoft.com/en-us/kb/3181507
  • In Windows Excel 2013 and 2016, if the Add-Ins ribbon is not shown automatically the first time when the add-in is loaded, close all workbooks, quit Excel, and restart Excel to display the Add-Ins ribbon. After the restart the ribbon will be displayed each time you start Excel.

What can I do if I see the error message “Cannot empty the Clipboard”?
See the discussion on our web page Clipboard-Cannot-Be-Emptied-Error.

In Mac Excel 2011, what can I do if I try to run a VBA add-in (TreePlan, SensIt, or SimVoi) and receive an error message like “Error in loading DLL,” “Excel could not open (the XLAM add-in file name) because some content is unreadable …,” or “Excel repaired or removed unreadable content from this workbook …”
See the discussion on our web page Cannot-run-XLAM-file-in-Mac-Excel-2011.

How do I uninstall an add-in?
If the add-in has been installed so that it appears in the Excel Add-ins Available dialog box, clear the checkbox of the add item and quit Excel. Then move or delete the add-in XLAM file. The next time you run Excel, respond to the prompts about Excel not being able to find add-in.

Back to top

 

TreePlan Questions and Answers

This section has information specifically for the TreePlan decision tree add-in.

For information related to all of our add-ins, see the more-general Add-ins Q & A section.

What is the shortcut key to run TreePlan on Windows Excel 2007 & 2010 & 2013 & 2016?
Control+Shift+T

What is the shortcut key to run TreePlan on Mac Excel 2011 & 2016?
Option+Command+T

Why does TreePlan not respond (or why does TreePlan show the wrong dialog box) when I select a node and choose Decision Tree (or press the shortcut key)?
(a) It is very important not to use Excel commands to insert or delete rows, columns, or cell ranges in the tree diagram area. If you do, TreePlan will not be able to keep track of the location of nodes (squares, circles, and triangles).
(b) TreePlan may not be able to detect selection of a node on some computers with a specific combination of display resolution and zoom setting. A workaround is to select the cell containing the node shape instead of selecting the node shape itself. To do so, select an adjacent cell, e.g., above or below, and then use an arrow key to select the cell containing the node shape. Then choose Decision Tree (or press the shortcut key).

When I run TreePlan on Mac Excel, the text and buttons on the dialog boxes are scrunched together and overlap, or TreePlan does not allow me to modify the decision tree. What should I do?
This behavior usually occurs if you double-click the XLAM file, in which case Excel does not execute some of the startup code that does special formatting for the Mac display. Instead, refer to the How To Install Addin PDF file, and try one of the methods for using the add-ins on the Mac. The simplest method is to launch Excel first and then use Excel’s File Open command to load the TreePlan XLAM file.

What should I do if I see “The item with the specified name wasn’t found”?
You may see this message only if (1) you are using Mac Excel 2011 and (2) there is no decision tree on the active worksheet and (3) you choose Tools > TreePlan Decision Tree and (4) you click the New Tree button. If you see this message box, click OK. TreePlan will continue as usual to create the new decision tree. To avoid seeing this message in Mac Excel 2011 when you create a new decision tree, run TreePlan by pressing Option+Command+T instead of choosing Tools > TreePlan Decision Tree.

How do I uninstall TreePlan?
If TreePlan has been installed so that it appears in the Excel Add-ins Available dialog box, uncheck the TreePlan item and quit Excel. Then move or delete the TreePlan XLAM file. The next time you run Excel, respond to the prompts about Excel not being able to find TreePlan.

How do I get a refund?
Uninstall TreePlan, delete all TreePlan files from your storage devices and computer, empty the Trash, and send an email to Mike Middleton <Mike@TreePlan.com> stating that you have done so and that you request a refund.

What can I do if I need a node with more than five branches?
For some workarounds, see our web page TreePlan Limit of Five Branches per Node.

 

SensIt Questions and Answers

This section has information specifically for the SensIt add-in for sensitivity analysis and tornado charts.

For information related to all of our add-ins, see the more-general Add-ins Q & A section.

In Windows Excel, why doesn’t the menu item appear in the Add-Ins ribbon, and why doesn’t the add-in respond to the shortcut key?
In July 2016 Microsoft released a security update which may affect downloaded XLA and XLAM add-in files with Windows Excel. After you load the add-in XLAM file, if the menu item does not appear in the Add-Ins ribbon and the add-in does not respond to the shortcut key, quit Excel. Use your file manager to navigate to the add-in XLAM file on your local drive. Right-click the XLAM file, and choose Properties > General. If there is an option to Unblock, click the checkbox and click OK. Then launch Excel, and use Excel’s File > Open to load the XLAM file, or follow the instructions for installation. For more information, see https://support.microsoft.com/en-us/kb/3181507

In Windows Excel 2007 & 2010 & 2013 & 2016, what is the shortcut key to run SensIt?
Control+Shift+P for SensIt Plot (one input, one output)
Control+Shift+S for SensIt Tornado-Spider (many inputs, one output)

In Mac Excel 2011 & 2016, what is the shortcut key to run SensIt?
Option+Command+P for SensIt Plot (one input, one output)
Option+Command+S for SensIt Tornado-Spider (many inputs, one output)

In Mac Excel 2016, how do I specify cells and ranges in the SensIt dialog box?
Currently the only way is to type the cell or range reference, e.g., B5 or B7:B11. The reference cannot be specified by the usual point-and-click on a cell or by a click-and-drag on a range of cells. The technical explanation is that the RefEdit control for a VBA UserForm does not yet work in Mac Excel 2016.

If you have Mac Excel 2011, we recommend using it instead of Mac Excel 2016. Mac Excel 2011 is a mature, stable product, whereas Mac Excel 2016 is an evolving product. If you must use Mac Excel 2016, be sure to obtain the latest updates.

How do I uninstall TreePlan?
If SensIt has been installed so that it appears in the Excel Add-ins Available dialog box, uncheck the SensIt item and quit Excel. Then move or delete the SensIt XLAM file. The next time you run Excel, respond to the prompts about Excel not being able to find SensIt.

How do I get a refund?
Uninstall SensIt , delete all SensIt files from your storage devices and computer, empty the Trash, and send an email to Mike Middleton <Mike@TreePlan.com> stating that you have done so and that you request a refund.

In Mac Excel 2011, what can I do if I try to run a VBA add-in (TreePlan, SensIt, or SimVoi) and receive an error message like “Error in loading DLL,” “Excel could not open (the XLAM add-in file name) because some content is unreadable …,” or “Excel repaired or removed unreadable content from this workbook …”
See the discussion on our web page Cannot-run-XLAM-file-in-Mac-Excel-2011.

Back to top

 

SimVoi Questions and Answers

This section has information specifically for the SimVoi Monte Carlo simulation add-in.

For information related to all of our add-ins, see the more-general Add-ins Q & A section.

In Windows Excel 2007 & 2010 & 2013 & 2016, what is the shortcut key to run SimVoi?
Control+Shift+V

In Mac Excel 2011 & 2016, what is the shortcut key to run SimVoi?
Option+Command+V

In Mac Excel 2016, how do I specify cells and ranges in the SimVoi dialog box?
Currently the only way is to type the cell or range reference, e.g., B5 or B7:B11. The reference cannot be specified by the usual point-and-click on a cell or by a click-and-drag on a range of cells. The technical explanation is that the RefEdit control for a VBA UserForm does not yet work in Mac Excel 2016.

If you have Mac Excel 2011, we recommend using it instead of Mac Excel 2016. Mac Excel 2011 is a mature, stable product, whereas Mac Excel 2016 is an evolving product. If you must use Mac Excel 2016, be sure to obtain the latest updates.

How do I uninstall SimVoi?
If SimVoi has been installed so that it appears in the Excel Add-ins Available dialog box, uncheck the SimVoi item and quit Excel. Then move or delete the SimVoi XLAM file. The next time you run Excel, respond to the prompts about Excel not being able to find SimVoi.

How do I get a refund?
Uninstall SimVoi, delete all SimVoi files from your storage devices and computer, empty the Trash, and send an email to Mike Middleton <Mike@TreePlan.com> stating that you have done so and that you request a refund.

In Mac Excel 2011, what can I do if I try to run a VBA add-in (TreePlan, SensIt, or SimVoi) and receive an error message like “Error in loading DLL,” “Excel could not open (the XLAM add-in file name) because some content is unreadable …,” or “Excel repaired or removed unreadable content from this workbook …”
See the discussion on our web page Cannot-run-XLAM-file-in-Mac-Excel-2011.

How do you pronounce “SimVoi”?
We pronounce “SimVoi” to rhyme with “Enjoy” with a slight emphasis on the first syllable.

Back to top

 


Recent Version History for TreePlan

 

TreePlan
Version
Release Date
(yyyy-mm-dd)
Description
2.06 2018-06-20 Modify behavior for defining name RT
2.05 2017-12-18 Revise XLM code to work with Mac Excel versions 16.8 and later
2.04 2017-03-10 Repair creation of risk utility defined names for each worksheet
2.03 2016-06-26 Restore compatibility with Windows Excel 2007
Avoid persistent menu item on Windows Add-Ins ribbon
2.02 2016-03-21 Fix Mac Excel run-time error when adding branch to initial decision node
Use TreeData node ID as part of name of node shapes
Include RiskTolerance function for calculating RT from two-outcome assessment
2.01 2016-02-02 Add yellow, green, and blue colors to node shapes
Repair behavior of risk tolerance defined name RT
Revise Mac Excel 2016 shortcut key reminder message
2.00 2015-10-09 Add compatibility with Mac Excel 2016
Improve multiple selection of cells and shapes
1.86 2014-10-16 Ensure that new tree diagram cells use the default Body Font
1.85 2014-09-26 Modify Copy & Cut functions to avoid using Office Clipboard
1.84 2014-07-11 Change Standard name to Pro with single-line menu items
1.83 2014-04-26 Change XLS & XLA files to XLSX & XLAM file formats
1.82 2013-08-19 Improve uninstall of menu item in Excel 2013
1.81 2013-02-26 Remove dropshadow from node shapes
Improve ability to detect selection of node shapes
1.79 2011-08-05 Fix error (present only in 1.78) for terminal value formulas
1.78 2011-06-09 Make all TreePlan-entered formulas compatible with non-English Excel
1.77 2010-12-30 Add compatibility with Mac Excel 2011
1.76 2010-12-07 Improve compatibility with Excel 2010
Improve selection of shapes with widescreen monitors
1.74 2010-01-13 Delete only decision tree shapes (graphic objects) before redrawing tree
Change shapes to be compatible with Windows Excel 2010
1.73 2009-03-13 Add ability for TreePlan to select an unlimited number of cells or shapes
Change terminal node symbol from vertical line to industry-standard triangle
Change zoom to 100% for redrawing tree and then restore to original zoom
Change calculation to manual before redrawing tree and then restore to original
Speed up redraw of tree diagram
Add compatibility with Mac Excel 2004

Back to top

Recent Version History for SensIt

SensIt
Version
Release Date
(yyyy-mm-dd)
Description
1.53 2016-06-26 Add workaround for Mac negative-valued XY chart axis title bug
Avoid persistent menu item on Windows Add-Ins ribbon
1.52 2016-02-02 Revise Mac Excel 2016 shortcut key reminder message
1.51 2015-03-25 Modify Plot feature to workaround Excel 2013 XY chart problem
1.50 2015-01-31 Improve speed by avoiding screen updates during computations
Repair accommodating identical input values for min, base case, and max
Repair problem updating data labels when tornado chart data are sorted
1.49 2014-09-15 Improve compatibility of one-input charts for some systems
Fix run-time error problem for some Mac non-English formats
1.48 2014-07-11 Change Standard name to Pro with single-line menu items
Improve compatibility of tornado charts for some systems
Fix compile-error problem for some non-English versions
1.47 2014-04-26 Change XLS & XLA files to XLSX & XLAM file formats
1.46 2013-08-19 Improve uninstall of menu item in Excel 2013
1.45 2010-08-21 Accommodate identical input values for minimum, base case, and maximum
Fix problem updating data labels when tornado chart data are sorted
1.44 2009-12-09 Accommodate negative values as inputs for spider charts
1.43 2009-08-19 Add ability to specify step for spider charts
Add two-factor tornado charts
1.31 2009-03-28 Add Percent Swing Squared to tornado charts

Back to top

Recent Version History for SimVoi

SimVoi
Version
Release Date
(yyyy-mm-dd)
Description
3.08 2017-12-18 Accommodate simulation variables that return a constant value
Detect cell error values in simulation results to avoid crash
3.07 2017-03-10 Add RandBeta and RandTriBeta random number generator functions
3.06 2016-06-26 Add workaround for Mac negative-valued XY chart axis title bug
Avoid persistent menu item on Windows Add-Ins ribbon
3.05 2016-02-02 Revise Mac Excel 2016 shortcut key reminder message
3.04 2015-10-09 Add truncated log normal random number generator function
3.03 2014-09-15 Fix run-time error problem for some Mac non-English formats
3.02 2014-07-11 Change Standard name to Pro with single-line menu items
Improve compatibility of value-of-information charts for some systems
Fix compile-error problem for some non-English versions
3.01 2014-04-26 Initial version for general release

Back to top